2

I used QGIS 3.2 Bonn and suddenly, and I don´t know why, the mouse pointer never stops rotating as the project is in work. It is still possible to click and select things like it is possible with the arrow pointer.enter image description here I installed the new version 3.6 now but the pointer remains busy. I deleted the folders c:/user/computer/.qgis but the pointer is still busy. Any ideas how to solve this problem?

  • 1
    you should give more infos: OS-System etc. – Kurt Mar 18 '19 at 16:23
  • o.k. I work with windows 7, 64 bit, any more information? – oppia04 Mar 19 '19 at 13:00
  • Is your project fully loaded ? – snaileater Mar 20 '19 at 12:20
  • Yes, the project is loaded 100% – oppia04 Mar 21 '19 at 9:12
  • Did you find a solution for the spinning cursor? I currently have the same problem with 3.2 and 3.4 and can't find the solution. – ClaKie Apr 2 '19 at 14:16
1

I found a reason for the spinning cursor.The failure is in the file: C:\Users\username\AppData\Roaming\QGIS\QGIS3\profiles\default\QGIS\qgis3.ini When I create a new profile (Menu/Settings/user profile/new profile) the cursor in the new profile is o.k. Sadly in this file all the settings are saved and if you copy it to the default profile you have to adapt everything. So I copied the file and renamed it to old_qgis3.ini. Then started qgis which created a new ini_file. After a couple of testings the spinning seems to be caused by some plugins. When I deactivated some plugins (with the original ini_file) the corsor stops running. This was sadly not consistent, but with a bit of try and error it works for me. I additionally deleted a online routing mapper plugin. The settings were saved and it works for me...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.