1

I converted a set of MapInfo files to SHP using org2gui. Unfortunately, the attributes got jumbled. The original dataset was in Chinese, so that is probably contributing to the jumbling. Screenshot below shows jumbles.

I uploaded the source Mapinfo files to filebin here, and I uploaded the converted SHP to filebin here.

Is there anyway to recover the jumbled attributes? I have opened SHP in ArcGIS with Chinese characters in the attributes before, so it's not solely a language character rendering issue.

enter image description here

5
  • 1
    It's a codepage problem, Chinese is a multibyte character system but how the multibytes are converted into characters depend on your codepage. Being monolingual in English I can't help much but I think you need codepage 936 en.wikipedia.org/wiki/Code_page_936_(Microsoft_Windows). Can I suggest you get QGIS and open the MapInfo file in that and experiment with your codepage gis.stackexchange.com/questions/219092/… until you understand the characters then use save as to export to shape. Mar 19 '19 at 5:28
  • Also another good link here: support.esri.com/en/technical-article/000013192 but it requires registry hacks which would really upset your I.T. support team. Mar 19 '19 at 5:37
  • @MichaelStimson wow, it worked!! (the first comment, not the formidable registry hacks, haha). I followed Victor's answer here (gis.stackexchange.com/questions/219092/…), setting the encoding to Windows-936 as you noted. Thanks so much for your help! If you want to move your comments into an answer, I'll mark it as accepted
    – a11
    Mar 19 '19 at 5:58
  • Considering this is a duplicate of another post the best thing to do is mark it as a duplicate and upvote the answer that worked for you. Mar 19 '19 at 6:03
  • Perfect, thanks. Upvoted @Victor on the duplicate page
    – a11
    Mar 19 '19 at 6:05