0

I'm trying to set up QGIS Server (2.18.18) with ISS (7.5) on my local machine with Windows 7 Ultimate 64bit.

I managed to get it running with Apache (XAMPP) without any problems, but I need QGIS Server running with IIS. I could really find a tutorial or anything on google. I tried following these instructions (https://domasin.github.io/valgrande/qgisserveriis.html) but never got the positive GetCapabilities request (just the download of the qgis_mapserv.fcgi.exe or Error 500.0 with code 0xc0000135).

Also tried following this one: https://github.com/mapserver/mapserver/wiki/Installing-Mapserver-under-IIS-7.n-with-FastCGI

..with the same results as mentioned above.

What am I missing?

0

I was looking for similar info and I found this thread :

http://osgeo-org.1560.x6.nabble.com/QGIS3-Server-on-Windows-Server-and-IIS-td5404369.html

There is a post at the bottom of the thread about Config on IIS. I have not tried it out myself yet but it might be helpful.

Here is the relevant bit from the posted link from Kasper@OSgeo-org:-

It's not so difficult, here's my setup:

Installation of qgis server 3.4.8 ltr from OSGeo4W64 on a Windows Server 2016

Windows Server roles, enable:

  • Web Server (IIS)
    • Web Server
      • Common HTTP Features
      • Default Document
      • HTTP Errors
      • Static Content
      • HTTP Redirection
    • Health and Diagnostics
      • HTTP Logging
      • Request Monitor
    • Performance
      • Static Content Compression
    • Security
      • Request Filtering
    • Application Development
      • ASP
      • CGI
      • ISAPI Extensions
      • ISAPI filters
      • Server Side Includes

Internet Information Services (InetMgr.exe)

  • Home
    • ASP
      • Enable Parent Paths = True
    • Handler Mappings
      • Request path: *.fcgi
      • Module: FastCgiModule
      • Executable: [path to qgis bin]\qgis_mapserv.fcgi.exe
      • Name: QGIS_fastCGI
      • Request Restrictions
      • Mapping
        • Invoke handler only if request is mapped to: File
      • Verbs
        • One of the following verbs: GET, HEAD, POST
      • Access
        • Specify the acces required by the handler: Execute
    • FastCGI Settings
      • Edit '[path to qgis bin]\qgis_mapserv.fcgi.exe'
      • Environment Variables (...)
        • Add (see list below)
    • Default Web
    • Alias 'qgis'
    • Physical path 'bin' directory qgis (..\OSGeo4W64\apps\qgis\bin or ..\OSGeo4W64\apps\qgis-ltr\bin)

Added a directory for the log and the server plugins ("[path to OSGeo4W64]\apps\qgis-server" and "[path to OSGeo4W64]\apps\qgis-server\plugins")

Environment Variables:

  • O4W_QT_PREFIX = "[path to OSGeo4W64]/apps/Qt5"
  • O4W_QT_BINARIES = "[path to OSGeo4W64]/apps/Qt5/bin"
  • O4W_QT_PLUGINS = "[path to OSGeo4W64]/apps/Qt5/plugins"
  • O4W_QT_LIBRARIES = "[path to OSGeo4W64]/apps/Qt5/lib"
  • O4W_QT_TRANSLATIONS = "[path to OSGeo4W64]/apps/Qt5/translations"
  • O4W_QT_HEADERS = "[path to OSGeo4W64]/apps/Qt5/include"
  • PATH = "[path to OSGeo4W64]\apps\qgis-ltr\bin;[path to OSGeo4W64]\apps\qt5\bin;[path to OSGeo4W64]\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32\WBem"
  • QGIS_PREFIX_PATH = "[path to OSGeo4W64]/apps/qgis-ltr"
  • QT_PLUGIN_PATH = "[path to OSGeo4W64]\apps\qgis-ltr\qtplugins;[path to OSGeo4W64]\apps\qt5\plugins"
  • TEMP = "C:\Windows\Temp"
  • PYTHONHOME = "[path to OSGeo4W64]\apps\Python37"
  • QGIS_SERVER_LOG_FILE = "[path to OSGeo4W64]\apps\qgis-server\qgis_server.log"
  • QGIS_SERVER_LOG_LEVEL = "0"
  • QGIS_PLUGINPATH = "[path to OSGeo4W64]\apps\qgis-server\plugins"

There is a problem with fonts in this version. See the fontloader example at https://github.com/avinet/qgis-server-font-loader https://github.com/avinet/qgis-server-font-loader , add it to the plugins and point it to the windows font directory.

  • 1
    Welcome to GIS.SE. Of course it would be great, if you tried your solution first yourself, but let's leave that aside. More important is the fact, that links change. Therefore please include the relevant passage from the linked website in your answer, so it wont become invalid, thank you. – Erik Dec 11 '19 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.