0

I was doing a GetFeature request call to a WFS service in Geoserver in json format with my application. I had initially installed 2.11.0, then when I moved to 2.15.0 my app stopped running,

I have discovered that the header response in the json is different depending on the Geoserver version I'm using,

In 2.11.0: {"type":"FeatureCollection","totalFeatures":56,"features":[

In 2.15.0: {"type":"FeatureCollection","features":[

So the number of total features is missing,

What Geoserver configuration step am I missing in order to get the same response?

  • which version of wfs are you requesting in each case? – Ian Turton Mar 19 at 15:29
  • VERSION=1.1.0. same version request – Web-GIS entrepreneur Mar 22 at 10:55
1

I think it is still there, just further along the list of attributes.

{"type":"FeatureCollection","features":[{"type":"Feature","id":"tasmania_cities.1","geometry":{"type":"MultiPoint","coordinates":[[147.291,-42.851]]},"geometry_name":"the_geom","properties":{"CITY_NAME":"Hobart","ADMIN_NAME":"Tasmania","CNTRY_NAME":"Australia","STATUS":"Provincial capital","POP_CLASS":"100,000 to 250,000"}}],"totalFeatures":1,"numberMatched":1,"numberReturned":1,"timeStamp":"2019-03-19T15:37:22.888Z","crs":{"type":"name","properties":{"name":"urn:ogc:def:crs:EPSG::4326"}}}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.