I have a shapefile in CRS EPSG:3111 - GDA94 that I am trying to generate Lat and Lon, however when I use the field calculator and try to populate the lat lon I am getting values that I can't use as per the screenshot below - enter image description here

I am expecting something in this format - enter image description here

I have projected it in EPSG:4326 but didnt help

enter image description here

  • I don't know the solution in QGIS, but you're getting the Vicgrid northing coordinate. You may need to reproject the layer to GDA94: EPSG:4283.
    – mkennedy
    Mar 20, 2019 at 23:47
  • @mkennedy have tried that but with no results. Have Set the CRS to 4326 and 4283 but the same Lat Lon is displayed
    – Duffer
    Mar 20, 2019 at 23:53
  • Please see this question.
    – mkennedy
    Mar 20, 2019 at 23:56
  • @mkennedy thanks, the layer is converted to CRS EPSG:4283 but when I try to generate the Lat using field calculator and use x_at(1) I get 2498498.3060000017
    – Duffer
    Mar 21, 2019 at 0:36
  • 1
    EPSG:3111 is a Lamberts' projection using the GDA94 datum, it's units are metres. GDA94/Geographic is, as stated, EPSG:4283. Changing to WGS84/Geographic (EPSG:4326) isn't helping, it's close but not the same. Please describe how you are projecting to a geographic coordinate system, I suspect you're simply overwriting the correct CRS with an incorrect one which won't change the numbers at all. Try right clicking on the layer in VicGrid 3111 and select save as then in the dialog implicitly specify EPSG:4283 and you should get Lat/Lon coordinates. Mar 21, 2019 at 0:59

2 Answers 2


You can reproject the shapes while computing the coordinate. Instead of using x_at(1), you can use

 x( point_n( transform( $geometry,'EPSG:3311','EPSG:4283'),1))

x(geom) -> get the X coordinate
point_n(geom, 1) -> get the 1st vertice
transform (geom, sourceCRS, destCRS) -> reproject

  • Thanks that worked
    – Duffer
    Mar 21, 2019 at 23:28

The steps JGH outlined will solve the issue if you are working from clean data. However, it seems you have incorrectly changed the CRS of your layer. Changing the CRS in the layer properties is not the same as re-projecting the layer.

Assuming that you changed the CRS in the layer properties, you have to fix that mistake before you can use the layer for anything. Change the CRS (in layer properties) back to the CRS it was before you changed it the first time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.