I work on UBUNTU 18.04 LTS/bionic, I am trying to compile QGIS 3.6.0, for an upgrade from QGIS 3.2. 0. I am facing the same trouble as several people the release compatibility between SIP and PyQT5 an more maybe.
For QGIS 3.2.0 compilation I worked with SIP 4.19.7 and PyQt5 5.11.3, I succeed the compilation.
For QGIS 3.6.0 I try PyQt5 5.12 and SIP 5.19.15 (GPL release). I download source tarball from RIVERBANK repository. I compile each of them, PyQt5 5.12 and SIP 5.19.15, with configure.py and PyThon 3.6.7. Everything seems OK installation are done. I remove any garbage (I think) about other SIP installation. I installed also QSCIintilla, release 2.11.1. The Qt release is 5.9.5
When, for QGIS 3.6.0, I prepare the Makefile with CMake, I have the following messages :
Traceback (most recent call last): File "/home/mbariou/WKSCOMPILE/QGIS/QGIS-final-3_6_0/cmake/FindPyQt5.py", line 34, in <module> import PyQt5.pyqtconfig ModuleNotFoundError: No module named 'PyQt5.pyqtconfig'
In fact I have not a such module but I have:
More, also this error message from CMake :
Found SIP version: 4.19.15 Traceback (most recent call last): File "/home/mbariou/WKSCOMPILE/QGIS/QGIS-final-3_6_0/cmake/FindQsci.py", line 45, in <module> from PyQt5.Qsci import QSCINTILLA_VERSION_STR RuntimeError: the sip module implements API v12.0 to v12.5 but the PyQt5.QtCore module requires API v12.6 Qsci sip file not found - disabling bindings for derived classes
I met the same difficulty when I compiled QGIS 3.2.0 the conflict was the same with other release, bit I succeeded in a random way it seems, in fact I downgrade to the Ubuntu 18.04/bionic distribution about PyQt5 and SIP.
But the following message is recurrent :
RuntimeError: the sip module implements API v12.0 to v12.5 but the PyQt5.QtCore module requires API v12.6
Can somebody deciphers this conflict and what are the release rules to respect between :
- QGIS ?