0

I'm using PostgreSQL 10.5 on a remote server (Debian). I created a database inside then I attempted to enable PostGIS but it wasn't successful.

I had this error : cache lookup failed for function 1

  • Have you tried any of the answers that such a search yields, such as this one. – John Powell Mar 23 at 17:21
  • I don't see how it could solve my issue! – zakaria mouqcit Mar 25 at 7:32
  • Well, it suggests that your error might be caused by database corruption. I have created lots of clean instances of Postgres/Postgis on Debian, Centos and Ubuntu servers and never seen this error, so, it is a decent guess. If the error were Postgis related, you would normally get errors about specifically named functions, not just function 1. Have you tried creating a non-spatial table, just to see if Postgres is working properly. – John Powell Mar 25 at 9:37
  • Yes I did try this, I created non geometric tables and it works as expected. The problem occurs while enabling postgis either via pgadmin or shell. This occurs not only for postgis but also for other extensions as well. – zakaria mouqcit Mar 25 at 9:46
  • I remember that prior to the 10.5 version a previous person was working with the 9.x version and he changed it to the actual one. May this switch cause such a bizarre behaviour or do you envision something else? I tried to update postgis yet when I did it I was told that I'm working with the updated one. – zakaria mouqcit Mar 25 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.