0

When trying to create PostGIS extension I am getting this error:

ERROR: cache lookup failed for function 1

I am running PostgreSQL 11 on Ubuntu 16.04. I have installed PostGIS and PostGIS scripts. I managed to create extension on one database but something caused this error so that I can't create it anymore.

1
  • Anyone any other solution? Same issue here on Ubuntu 18.04.1, postgis 2.4 and postgresql 10.8. The server has multiple databases instances running without an issue. I reinstalled postis. I reindexed all databases. I tried to run the postgis.sql manually.
    – Nacky
    Commented May 30, 2019 at 10:41

1 Answer 1

1

The "cache lookup failed" errors seem to be related with corrupted tables or databases. I'd try dumping the content of the database into a file and recreating and restoring the database.

6
  • I have nothing to dump since I have just created this database and its empty Commented Mar 24, 2019 at 19:18
  • Better then. Drop it and create it new again Commented Mar 24, 2019 at 23:17
  • It does not help unfortunately. I get the same error message. Commented Mar 25, 2019 at 8:20
  • Have tried to reinstall PostGIS? Commented Mar 25, 2019 at 11:44
  • I have reinstalled it. But it didn't help either. I think it lies on psql side. Commented Mar 25, 2019 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.