0

I have a large shapefile (~10 Gb) which it output of Atoll (RF Coverage) and I need to perform some post-processing on it.

I began by importing the file in a file geodatabase, the file was imported without problems, but when I run a geoprocessing it raises errors of invalid geometries and the famous 999999. I tried to execute repair geometry but in vain.

I tried to import the shapfile in a PostGIS database using shp2pgsql but during the importing the process stops.

I am stuck on the problem for more than a week, any ideas of how to solve the problem?

  • What were the full error messages that you received from trying to Repair Geometry? – PolyGeo Mar 25 at 10:33
  • 4
    It is not possible to have a 10Gb shapefile. Any such file is hopelessly corrupt and cannot be safely read. – Vince Mar 25 at 10:36
  • When i run Repair Geometry, the process ends succesfully, but the file is still invalid because when I try to run another geoprocessing it raises the same error (invalid geometry), I tried to run Repair Geometry many times on the same file using an iterator but no result, – geocoder Mar 25 at 10:36
  • @Vince, that's the problem I guess, do you know how to split it into smaller pieces? – geocoder Mar 25 at 10:37
  • 4
    Whatever process is creating the corrupt file is at fault. That is where you need to address this. – Vince Mar 25 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.