I'm following the tutorial at http://www.hibernatespatial.org/tutorial-hs4.html. I've created a maven project, and imported it into Eclipse. However, when I run mvn dependency:list, I get the error Missing artifact org.postgis:postgis-jdbc:jar:1.5.3. The same error is reported from within Eclipse. Any idea on what I may be doing wrong?


I sorted this issue by: 1. Added maven-compiler-plugin dependency

  1. Added postgis-jdbc dependency that is available in the maven repository. As it turns out, version 1.5.3 is not available in the maven repository, and I was not in the mood to compile the jar. So, I just added:

And that sorted it out.

  • postgis-jdbc dependency could as well be replaced with version 1.5.2, which is also available in the maven repository. – okello Aug 27 '12 at 8:50
  • @RyanDalton, sorry for the delay. – okello Sep 18 '12 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.