0

Downloaded QGIS 3, downloaded Grass 7. Opened QGIS version 2.18.21. I get the following error message:

2019-03-27T19:42:38 1   Traceback (most recent call last):
              File "/Users/CMM/.qgis2/python/plugins/openlayers_plugin/openlayers_layer.py", line 141, in pageLoaded
                self.checkMapReady()
              File "/Users/CMM/.qgis2/python/plugins/openlayers_plugin/openlayers_layer.py", line 148, in checkMapReady
                self.setup_map()
              File "/Users/CMM/.qgis2/python/plugins/openlayers_plugin/openlayers_layer.py", line 201, in setup_map
                olSize = QSize(int(olWidth), int(olHeight))
            OverflowError: cannot convert float infinity to integer
            "

My laptop is running apples OS Mojave ( 10.14.2 (18C54)). What does the error message mean ? I read a post that said that the project CRS hast to be set to EPSG:3857 in order for open layer to work. I set it to EPSG:3857, saved, closed and reopened QGIS, but still get the same message.

  • Please edit your question to include whether this just started happening after an update (of QGIS, Python, or your OS) or if it's a fresh install of QGIS. (e.g. has it ever worked?). Also see this question to see if it might apply: gis.stackexchange.com/questions/115371/… – smiller Mar 27 at 19:03
  • Yes, it started happening after I installed QGIS 3. Everything seems to be working alright though. Had a look at the thread that you sent, followed the instruction, it didn't do away with the rerror message. – charlie mike Mar 27 at 19:33
  • 1
    It'not clear about the QGIS 3 and QGIS 2 problem. Does the problem occurs only in QGIS 2? I can't see how QGIS 2 and QGIS 3 are linked as the error is coming from the OpenLayers plugin in QGIS2 folder. Remove OpenLayers plugin and use QuickMapServices instead. – etrimaille Mar 27 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.