0

Running GeoServer 2.14.2 on Linux/Ubuntu

I have an Image Mosaic layer using a postgres table as the index. Rather then allowing GeoServer to insert the rows into the table I have a ready created table with the correct paths of each image. This works and GeoServer is correctly displaying the right images. However, footprints of any sort do not work. I have tried sidecar chain shape files, one shape file called footprints.shp and set the layer to transparent to clip the image to the footprints. I have also tried with footprint.properties with various options with both the footprints in the same relative path as the .properties files and with the images themselves.

If I select a folder and generate a shapefile indexed image mosaic layer the footprints work as expected and clip the images. Therefore the issue is not with either the sidecar shapefiles or the footprints.shp options. A quick dig in the code (I am not a Java developer) showed this comment;

* A set of properties to be ignored when parsing the properties file. It is used to get only * the FootprintManagement property, avoiding by this way to load and compute useless elements. */

Therefore I am worried that footprint support does not work at all for DB based indexed image mosaic layers.

There are no obvious signs in the logs that anything is a miss.

  • I believe this might be a relative path issue but I need to do more testing to make sure. Using full path seems to have fixed it. – Mark Allen Mar 28 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.