0

I am having trouble diagnosing where this error is occuring. The error is thrown when you start the web application, while the ArcGIS API is loading in the map layers. It seems to be thrown in the 'init.js' file of the API (see full stack trace below).

I've narrowed it down to an issue with one of our layers. Removing it from the map does not trigger this error. However, I cannot figure out what is wrong with the layer that is causing this issue. I have tried catching the error so that the web application can at least finish loading, but I can't seem to figure out how to do so.

Full Stack Trace:

init.js:formatted:2897 TypeError: Cannot read property '_getInfo' of undefined
    at Object._setMap (init.js:formatted:27977)
    at Object._attachLayerToMap (init.js:formatted:14204)
    at Object._addLayerHandler (init.js:formatted:14148)
    at init.js:formatted:1515
    at Object.d (init.js:formatted:14127)
    at Object.c [as onLoad] (init.js:formatted:3059)
    at Object._attachLayerToMap (init.js:formatted:14238)
    at Object.<anonymous> (init.js:formatted:14146)
    at init.js:formatted:1515
    at c (init.js:formatted:2577) "TypeError: Cannot read property '_getInfo' of undefined
    at Object._setMap (http://js.arcgis.com/3.27/init.js:1119:42)
    at Object._attachLayerToMap (http://js.arcgis.com/3.27/init.js:578:146)
    at Object._addLayerHandler (http://js.arcgis.com/3.27/init.js:575:56)
    at http://js.arcgis.com/3.27/init.js:64:337
    at Object.d (http://js.arcgis.com/3.27/init.js:573:254)
    at Object.c [as onLoad] (http://js.arcgis.com/3.27/init.js:120:193)
    at Object._attachLayerToMap (http://js.arcgis.com/3.27/init.js:580:125)
    at Object.<anonymous> (http://js.arcgis.com/3.27/init.js:574:356)
    at http://js.arcgis.com/3.27/init.js:64:337
    at c (http://js.arcgis.com/3.27/init.js:104:393)"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.