0

I have installed Mapnik and have a functioning PostGIS database (I can access data through QGIS with no problems). When I try to run render_list to generate tiles it fails with

socket connect failed for: /tmp/osm-renderd

I have updated datasource-settings.xml.inc to include proper connection settings for my database but still no luck.

Here is my datasource-settings.xml.inc:

<!--
Settings for your postgres setup.

Note: feel free to leave password, host, port, or use blank
-->

<Parameter name="type">postgis</Parameter>
<Parameter name="password">gis</Parameter>
<Parameter name="host">localhost</Parameter -->
<Parameter name="port">5432</Parameter -->
<Parameter name="user">www-data</Parameter>
<Parameter name="dbname">gis_data</Parameter>
<!-- this should be 'false' if you are manually providing the 'extent' -->
<Parameter name="estimate_extent">true</Parameter>
<!-- manually provided extent in epsg 900913 for whole globe -->
<!-- providing this speeds up Mapnik database queries -->
<!-- Parameter name="extent">%(extent)s</Parameter -->

I'm running Ubuntu 12.04. My database is on localhost at port 5432. OSM data is located in a database called gis_data under a schema called osm_data. The tables all have public permissions so I don't see that being the issue. Googling around didn't yield much help other than double- and triple-checking the permissions on my database. Any suggestions? Is there another settings file somewhere that I need to be looking at?

1

You'll need to /etc/init.d/renderd as sudo, then run render_list as sudo as well. I've also gotten it to work by doing both of the above as the www-data user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.