2

This morning I have been trying to clip, extract, do anything with a DEM in V3.4 on a mac10.14.3 (it works fine on linux Debian).

I receive an error message in the dialog box - attached and the log messages indicates '/bin/sh: gdal_translate: command not found'

I installed Madeira (3.4) from the main site, not through Kyngchaos, and using python 3.6.x as instructed in the dmg file.

log messages panel

error in dialog box.

  • looks like it can't see gdal_translate – Ian Turton Apr 11 at 11:04
  • Yes that's the case, How can I make it see gdal_translate? – Eoin O'Mahony Apr 11 at 11:20
  • 1
    You need to edit your question - probably remove reference to tempDIR and add in how you installed qgis and gdal – Ian Turton Apr 11 at 12:15
  • @gene: this has been rectified through an earlier build according to this linked post. Also I tried this workaround and still no joy. and finally, the url to kyngchaos is 404'ed. – Eoin O'Mahony Apr 11 at 15:21
0

The content of the QGIS 3.6.pkg package is

enter image description here

The scripts are installed in /Library/Frameworks/GDAL.framework/Versions/2.4/Programs

enter image description here

And in the Read Me.rtf file:

External Program Paths
QGIS 3 does not find external tools needed for Processing. Some configuration options are missing. A workaround is to use QGIS custom variables.

  • Open QGIS Preferences → System.
  • Under the Environment section, turn on Use Custom Variables.
  • Add (+) a variable
  • Select Prepend from the Apply popup
  • Enter PATH for the variable
  • For the Value enter: /Library/Frameworks/Python.framework/Versions/3.6/bin:/Library/Frameworks/GDAL.framework/Versions/2.4/Programs:
  • Quit QGIS 3 and start it again NOTE: this may need to be updated when upgrading from a previous version of QGIS.
  • Thank you for this. I have tried this and it has not rectified the problem. No difference in the error messages. – Eoin O'Mahony Apr 12 at 10:55
  • I suspect this same problem may be preventing me using the Hotspot Analysis plugin for 3.x. QGIS seems to draw from earlier python install i.e. 2.7. Is this possible? and if so, how can I correct this? – Eoin O'Mahony Apr 28 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.