3

I have worked with netCDF files in QGIS before, but since I installed QGIS 3.6 they won't load ("myfile.nc" is not an admitted raster data source), nor do they load in QGIS 2.18 anymore. I find this particularly strange. I am working under Windows 10. It appears both versions of QGIS are using GDAL 2.2.4. I don't know if that is the problem but when I run gdalinfo --formats on the OSGeo4W Shell, netCDF does show up:

netCDF -raster,vector- (rw+s): Network Common Data Format

I was looking for a way to downgrade GDAL in case this was the problem but did not find anything feasible at my level. Any help would be welcome.

  • Can you post some more metadata about your NetCDF dataset, such as an ncdump -h? – Richard Law May 21 at 21:02
1

In QGIS 3.6 NetCDF are loaded differently if they have a single variable or multiple. With one variable it work as before in QGIS 2.8. With more than one variables, then 3/2 dimensions need to have the names X,Y,Time or longitude, latitude and Time. GDAL gives a warning for this but in QGIS it seems mandatory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.