0

My geoprocessing tool has 2 inputs 1 output. 1st input parameter type is a feature layer 2nd input parameter type is a String 3rd output parameter type is a shapefile when I run it, the window was as follows

enter image description here

The tool works successfully in arc desktop version. Then I published it as a GP server and when I run it in arc desktop after connecting to the server its window appears without 3rd output parameter as follows. But it works successfully. enter image description here

In my second step, when I pass parameters to GP server through a javascript, it says job succeeded at the first time of the day and all other Occasions in the day, it says job-failed. When I checked the result parameter(job id ), it says null and JSON code was { "error": { "code": 400, "message": "Unable to complete operation.", "details": [ ] }}

Another occasion JSON code was ;

{ "error": { "code": 400, "message": "Invalid or missing input parameters.", "details": [ ] }} When I check the result in the server under the job id folder, scratch, and scratch.gdb folders have been created. But the output feature layer file was not created. What is the mistake I have made here?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.