I want to pull data from Berlins Geo portal (FIS BROKER). When I do the query in the browser (Firefox) or through FME Workbench, it returns fine:

Eg.: https://fbinter.stadt-berlin.de/fb/wfs/data/senstadt/s_wfs_alkis_ortsteile?service=WFS&version=2.0.0&request=GetFeature&TYPENAMES=fis:s_wfs_alkis_ortsteile&srsName=urn:ogc:def:crs:EPSG:6.9:25833&BBOX=390812,%205821130.01,%20392562,%205819077.24

When I add a layer in QGIS, it loads everything…

Could somebody help me with this?

  • Did you use the option to restrict to area of interest
    – nmtoken
    Apr 13, 2019 at 9:29
  • good question... is that an option within qgis?
    – Joseph
    Apr 13, 2019 at 9:50
  • Yup, in the data source manager, 'Only request features overlapping the view extent'
    – nmtoken
    Apr 13, 2019 at 9:52
  • ah yeah... if you set up the connection that option is checked by default. thats neat, but then you cant zoom in/out without downloading more data then you need. Have you been able to bbox wfs urls?
    – Joseph
    Apr 13, 2019 at 10:08
  • You could also write a query
    – nmtoken
    Apr 13, 2019 at 11:12

2 Answers 2


'Only request features overlapping the view extent' while you load the wfs do the work!

  • 1
    i d prefer to actually define the request within coordinates... see prev post. it prevents from downloading more if you zoom out.
    – Joseph
    Apr 13, 2019 at 10:10

You can use the SQL Query Composer to restrict the extent (using the Build query option when editing the server connection).

Initial Data Source Manager for WFS

Specifying a spatial query as the WHERE clause


as below:

SQL Query Composer

Giving connection as:

Data Source Manager for WFS with SQL query

The result of the filtered WFS is shown (below) as orange polygons (note funnel icon in Layers panel) on top of the unfiltered WFS showing in purple.

Filtered WFS layer in QGIS

More information on spatial functions can be found on the GDAL WFS driver page: https://gdal.org/drivers/vector/wfs.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.