1

I want to use the GeoRSS from USGS, followed the a) add vector layer b) paste URL: https://earthquake.usgs.gov/earthquakes/feed/v1.0/summary/all_hour.geojson and c) add

But I always get the error: "not a valid source"

I am missing something? W10 enterprise /64bits + QGIS 3.6.0

1
  • I tried the GeoJSON like in this blog post (webgeodatavore.com/…) and it's not working, neither the dialog method, nor the PyQGIS way. Apr 14 '19 at 9:33
1

It just worked for me (3.6.1) - I went to the add vector dialog selected Protocol and pasted in the URL.

enter image description here

QGis then claims it hasn't worked as a protocol, would I like to try file and when I said yes it worked fine.

enter image description here

4
  • 3.6.1 on W10, it doesn't work. On which OS do you tried ? Apr 14 '19 at 10:13
  • I'm using Ubuntu 18.04
    – Ian Turton
    Apr 14 '19 at 10:37
  • I am using Windows 10 Enterprise 64bits Apr 14 '19 at 15:32
  • 1
    I confirm : on Windows 10, it doesn't work, on Ubuntu 18.04, it works on QGIS 3.6.1. For me, it's a QGIS bug on Windows. Apr 15 '19 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.