I'm very new to QGIS, but in the past days I've created 3 different maps. I have now downloaded DEM data in ASC format, and when I open it as a raster file in a new QGIS project there is no problem, I switch it to hillshade and it displays perfectly. The problem is when I want to have this DEM in the same file as my 3 maps (polygons). It loads, but it is not visible.

If I open my 3 maps and then load my DEM, the DEM doesn't show. And if I open the DEM in a new blank file, and I load my polygons from my 3 maps, the polygons don't show. It's as if they're not compatible with each other.

I've also opened the DEM in ASC format and exported it as GeoTIFF, and afterwards I loaded the GeoTIFF format into the file where my maps are, but the the DEM still doesn't appear.

  • I assume your DEM shows up somewhere in nowhere on your map. Use zoom on layer to check this. Then I'd suggest to check georeference of your layers and their CRS.
    – MrXsquared
    Commented Apr 14, 2019 at 21:01
  • @MrXsquared Hi, thanks for your answer. The problem is that georeferencing isn't necessary, it's already been done by the people who made it. And the DEM is also huge, it wouldn't be small at all. Commented Apr 14, 2019 at 21:21
  • 1
    I meant it might have the wrong crs assigned.
    – MrXsquared
    Commented Apr 14, 2019 at 21:38
  • Or no CRS assigned and the project/other layers have a different CRS.
    – user2856
    Commented Apr 15, 2019 at 0:24
  • 1
    We can start with this: Where did you get your DEM from? And where is your DEM located at and where should it be located at?
    – MrXsquared
    Commented Apr 15, 2019 at 16:14

1 Answer 1


Try this check-up of the situation:

  1. Right-click on every layer name, go to "zoom to layer". If you can't see the same position of polygons layer on the map, the problem is coordinate reference system of layer.
  2. Set the correct crs for each layer of your maps (righ-click on the layer name > Set CRS).
  3. If you're using QGIS 2.8 or earlier check "enable on-the fly CRS transformation".
  • Hello, thanks for your help. Now I know what CRS is, but the program asks me to set the CRS when I open the DEM into the project. Anyway, I've set the CRS again, but nothing changes. Commented Apr 15, 2019 at 11:51
  • Can you write here the two EPSG code of the layers? Commented Apr 24, 2019 at 14:11
  • I have the same problem, and it isn't related to the CRS. I created a new GeoTIFF file from DEM data. Everything was ok in the first session after it finished processing, but when I tried to load the file in a new session, it didn't show. The file appears in the Layers tab, but is grayed out and doesn't show the raster value range as it should. In the symbology settings, it shows the image in greyscale in the "Thumbnail" window, and when I zoom to location, it merely zooms out above my other layer, where it should be. It just doesn't show. Commented Nov 24, 2020 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.