2

I have multiple polygons aligned next to each other. They are colorfilled with "Graduated" style. I have changed "Stroke style" to "No Pen". How can I get the hairline between the polygons to disappear, so it is only the color fill one see?

enter image description here

  • 1
    You could change the border colour to the fill colour. – Erik Apr 15 at 11:57
  • @Erik, the colors will change, depending on the color ramp and classes in my graduated fill. How can I lock the edge-color to the fill-color? – TobiasDK Apr 15 at 12:03
  • @JGH, where should I make these changes? – TobiasDK Apr 15 at 12:25
3

The easiest way is to have a small border and set that border to the same color as the polygons.

This can be done automatically by setting the border color to @symbol_color.

So graduated symbology, click on the Symbol at the top without highlighting any of the individual classes, this means that all of them will be edited:

enter image description here

Then we set a data defined override for the stroke color:

enter image description here

Which is just set to @symbol_color, which will use the same color as the main color:

enter image description here

  • It does. When you are editing from that top symbol button with none of the classes selected it applies the same edits to all of the classes. So it calculates @symbol_color for each class. I'm on 3.4 as well. This has been the behavior since probably 1.8. – HeikkiVesanto Apr 16 at 11:30
  • Thanks for double-checking.. you are right, it works as you describe... I'm not sure why it failed on me yesterday – JGH Apr 16 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.