0

I have joined a csv file (via the add spreadsheet layer plugin) and the field types have saved correctly (i.e. they are "real" types, see attached image), and yet the graduated style renderer option is not available. I have several numeric fields showing percentages and total numbers that I would like to display as graduated classes. Any advice? Ideas on why the graduated style option is not showing? See image of current style window. I am using QGIS version 2.18.23

Field types correct

Style window without graduated renderer option

2

You are selecting Single symbol which is the default style when you click on Layer Properties -> Style. You need to change the Single symbol to Graduated:

enter image description here

Then, under Column, select the field that you need to show its graduated color. If you still couldn't see the numerical field under Column, then save your CSV file as a shapefile and try again the same steps using the shapefile.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.