0

When I try to add a new WMS Layer from an URL into QGIS, it seems I can add the layer but when I try to open it I get the following error message: "invalid layer: raster layer data provider is invalid".

Any idea where the problem is? Is it the URL (which should be correct) or something with my QGIS. I'm using the QGIS 3.4.6 Version.

the WMS URL used was: "https://www.wms.nrw.de/gd/bk050?"

I have not used an other Provider because it is the only one I know for these data

  • 2
    Sorry, but it is impossible to give an answer with these details. Could you share the WMS URL? Have you tested with some other WMS server that is known to be good? – user30184 Apr 16 at 12:25
  • hi, thanks for the Reply. The WMS URL is: wms.nrw.de/gd/… – Dennis Jan Apr 16 at 12:34
  • 1
    Works for me with QGIS 3.4.4. – user30184 Apr 16 at 14:39
  • 1
    I tried several layers and they all worked for me in QGIS 3.6.1. That service has many layers; please specify which ones aren't working for you. Are any of them working? – csk Apr 16 at 19:36
  • 1
    In order to avoid a too big data load for the server, some detailled WMS only become visible at large scales. E.g. cadastral data (ALKIS) for Brandenburg is only visible at 1:5000 or larger. – Erik Apr 17 at 8:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.