5

I have an OSX Mojave setup where I've already installed PostGIS and GDAL using Homebrew.

Now I'd like to install QGIS. I'm trying:

brew install qgis

But... I'm getting lots of warnings of the form:

osgeo-postgis: You have other linked versions!

I'm using PostGIS in various projects, so I would prefer to avoid breaking / version-changing anything that's currently running if possible, though I can do so if absolutely necessary.

What do I need to do to install QGIS?

Here's the full output:

==> Installing osgeo-qgis from osgeo/osgeo4mac
osgeo-proj: You have other linked versions!

Unlink with brew unlink proj or remove with brew uninstall --ignore-dependencies proj

osgeo-libgeotiff: You have other linked versions!

Unlink with brew unlink libgeotiff or remove with brew uninstall --ignore-dependencies libgeotiff

osgeo-libspatialite: You have other linked versions!

Unlink with brew unlink libspatialite or remove with brew uninstall --ignore-dependencies libspatialite

ant: Java 1.8+ is required to install this formula.
JavaRequirement unsatisfied!
You can install with Homebrew Cask:
  brew cask install java
You can download from:
  https://www.oracle.com/technetwork/java/javase/downloads/index.html
osgeo-netcdf: You have other linked versions!

Unlink with brew unlink netcdf or remove with brew uninstall --ignore-dependencies netcdf

osgeo-postgresql: You have other linked versions!

Unlink with brew unlink postgresql or remove with brew uninstall --ignore-dependencies postgresql

osgeo-gdal: You have other linked versions!

Unlink with brew unlink gdal or remove with brew uninstall --ignore-dependencies gdal

osgeo-postgis: You have other linked versions!

Unlink with brew unlink postgis or remove with brew uninstall --ignore-dependencies postgis

osgeo-grass: XQuartz 2.7.11 (or newer) is required to install this formula. X11Requirement unsatisfied!
You can install with Homebrew Cask:
  brew cask install xquartz
You can download from:
  https://xquartz.macosforge.org
mesa: XQuartz 2.7.11 (or newer) is required to install this formula. X11Requirement unsatisfied!
You can install with Homebrew Cask:
  brew cask install xquartz
You can download from:
  https://xquartz.macosforge.org
osgeo-openscenegraph: XQuartz 2.7.11 (or newer) is required to install this formula. X11Requirement unsatisfied!
You can install with Homebrew Cask:
  brew cask install xquartz
You can download from:
  https://xquartz.macosforge.org
freeglut: XQuartz 2.7.11 (or newer) is required to install this formula. X11Requirement unsatisfied!
You can install with Homebrew Cask:
  brew cask install xquartz
You can download from:
  https://xquartz.macosforge.org
osgeo-proj@5: You have other linked versions!

Unlink with brew unlink proj or remove with brew uninstall --ignore-dependencies proj
6

I had the same problem and figured it out. You did brew tap osgeo/osgeo4mac before and thereby expanded your brew with the osgeo-tap. The repository documentation mentions they are currently 'renaming' formulae. It turns out they're renaming formula postgresql to osgeo-postgresql etc. So my trick was to type on the shell:

for f in libgeotiff libspatialite netcdf postgresql gdal postgis sip qscintilla2 pyqt; do brew uninstall --ignore-dependencies $f; done

This will uninstall the currently installed relevant formulas from osgeo. Next, install the formulae with the new name (prefixed with osgeo-) with:

for f in libgeotiff libspatialite netcdf postgresql gdal postgis sip qscintilla2 pyqt; do brew install osgeo-$f; done

Once finished, you should be able to install osgeo-qgis with:

brew install osgeo-qgis
  • if it fails with Error: Too many open files @ rb_sysopen , do a ulimit -n 1024 first
  • it will take a while, the amount of direct/indirect dependencies is quite large

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.