0

enter image description hereenter image description hereI am trying to count points within polygons (311 calls by Census tract). Both shapefiles are EPSG 4326, and I've done define projection just to double-check. Every time I run Join attributes by location (summary) all values come back NULL. If not the projection, what else can cause this, or, if it is the projection, what else can I do to check?

  • can you post some screenshots or something to be sure you assigned the right things? – PieterB Apr 19 at 11:16
  • May be you uncheked PREDICATE or trying to Join layers in incorrect order (target and join) ? – Sergey N Apr 19 at 11:22
  • Just added screenshots. I noticed that the code says 'SUMMARIES' : [0] } even though it shows I selected an element. Maybe that's it? – Rosalie Apr 19 at 11:28
  • Update: I tried using a different summary measure 'Unique' instead of Count, and it returned all 1s, which is accurate (the field has only one value). So why can it recognize that but not count? – Rosalie Apr 19 at 14:34
0

I needed to use both intersect and within. Even though all the points were within a polygon zoomed in far enough, it wasn't capturing them for some reason.

  • 1
    I tested on Windows with QGIS 3.6.1, and it made no difference whether I chose "within" or "intersect" for the geometry predicate. It looks you're on a Mac, and for a while QGIS had a number of Mac-specific bugs. I think you should report this as a bug at issues.qgis.org. – csk Apr 19 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.