4

I cannot access layers properties (i.e. change color, filter by query, anything). The mouse right click doesn't do anything.

Is there a way restoring qgis to default?

Ubuntu 12.04, QGIS 1.8

4
  • could you access the layer properties before or did it not work for you from the start?
    – Kurt
    Aug 22, 2012 at 8:52
  • 1
    if you need to restore QGIS settings under Linux just delete the ~/.qgis and ~/-config/QuantumGis folders Aug 22, 2012 at 9:32
  • Kurt - I could access it. it suddenly disappeared. Giovanni - Thanks, moving these two files away solved the problem out (though loosing many of customization...)
    – OLS
    Aug 22, 2012 at 13:04
  • Opss... I forgot to mention to backup that folders? :) Aug 23, 2012 at 8:22

4 Answers 4

2

It is probably a symptom of something I encountered today where the layers panel was deactivated and the order panel activated after I restarted QGIS. In the order panel, everything looks like the layers panel but of course there are no context menus on legend items.

1
  • This was the fix for myself. Jan 23, 2014 at 14:13
1

If you need to restore QGIS settings under Linux just delete the ~/.qgis and ~/-config/QuantumGis folders (backup them first if you have any particular setting you may not want to loose).

0

I had the same problem - I solved it as Tim mentioned:

I closed the layers panel and just enabled it again (in the view tab). Afterwards, it was working fine again. I think this started, when I was moving the layers panel, due to the use of an external monitor.

Best,

Ziga

0

In the view menu, scroll down to panels and select layers (not layer order), then you will see the symbol under the layer name. In this case you can right click and go to properties.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.