3

This may be an easy one but I am not a statistician so it's something I'd like an answer to.

I have a polygon feature class loaded in ArcGIS Pro that contains a field with values ranging from 1 to around 1200. I am attempting to use graduated color symbology to display the relative difference in values based on that field.

However, no matter what way I symbolize it (Quantile is what I'm after, but have tried others), it will not pick up 1200 as the max value. It lists 661 as the max value for the field, and then refuses to render values above that.

I have around 163,000 rows in the FC. Of that, approximately 200 rows fall above 661.

How do I get ArcGIS Pro to make the maximum value for graduated colors, the actual maximum value of the field?

UPDATE: I tried a few more things:

  • Creating a completely new feature class and loading it from scratch into ArcGIS Pro. Didn't matter, still cut off at 661 when doing any graduated symbology.

  • Loaded the same data into QGIS (3.4). Upon setting it to graduated
    symbology, it picked up the min/max values without issue and used
    them properly for each of the preset classification schemes.

So it seems that Pro is doing some sort of automatic range boundary setting for large datasets; perhaps in an attempt to be "helpful."

  • Have you tried manual interval as the classification method and set your top bin as ≤ 1200? You can try Quantile to set the bins, then select manual interval, then change the upper bound of the top bin or do any other tweaking that is necessary. – lambertj Apr 22 at 16:39
  • @lambertj Yes, I've tried that; however when I then set it back to Quantile or Natural Breaks, it drops back down to 661. I will add an update reflecting that when I load this same data into QGIS, it does not behave in this way. It picks up correct min-max values without issue. – auslander Apr 22 at 17:10
4

I've been given an answer by Esri for this and list it here in case anyone ever stumbles across the same problem.

ArcGIS Pro takes a sample from the data in order to find its min-max values. This sample by default is set to 10000.

If a user changes that sample size through the overflow (hamburger) menu on the Symbology tab to a higher number, it will read the min-max values correctly. In my case I had to set the sample size to 163000 because so few rows out of the whole were higher than 661.

The reason it works in QGIS without this is apparently because QGIS does not use a sample size; it just calculates the min-max of the data from the entire data frame by default.

  • Very interesting. I wasn't aware that ArcGIS Pro is using a sample of the data to calculate min-max values for symbology. – lambertj Apr 22 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.