3

I am running ArcGIS Server Manager and Portal for ArcGIS. Unfortunately, some of my map services aren't working correctly, and I think it has to do with the Managed Database called ArcGIS_Data_Store. It was just working fine the other day. What should I do to fix this?

ArcGIS Server Manager - Data Stores

3 Answers 3

3

Portal for ArcGIS services sometimes will fail to work or publish correctly if there are issues with the main ArcGIS Server "Managed Database" data store called ArcGIS_Data_Store. Navigate to the ArcGIS Server Manager data store page at http://..com/server/manager/site.html as the admin user and click the checkbox next to ArcGIS_Data_Store, then click Validate. If you have a red exclamation point pop-up, like the one shown in the question, you might need to restart the Data Store Machine.

To attempt to restart the Data Store Machine, go to the Server Admin Data Store Machine Properties page (URL looks something like this: https://gisserver.domain.com/server/admin/data/items/enterpriseDatabases/AGSDataStore_ds_wztxj7um/machines/GISSERVER.DOMAIN.COM)

ArcGIS Server Administrator Directory - Data Store Machine Properties

Click start, change the format to JSON, and click Start.

ArcGIS Server Administrator Directory - Start Datastore Machine

It may take a few minutes for the Data Store Machine to start up. When it is done you should see a message that says {"status": "success"}. When you do, return to the ArcGIS Server Manager data store page and validate the data store again. It should now have a green check mark next to it. If not, you may need to reach out to Esri Technical Support for further troubleshooting.

2
  • So ... do you know the source of the problem ? We restart the service as well but the problem reappears after a few days.
    – Olyster
    Commented Sep 5, 2019 at 13:16
  • It’s possible there may be issues with the index. Unfortunately there is not much in the way of good documentation on this front, and you may need to follow up with ESRI Tech Support to troubleshoot the recurring issue. Commented Sep 6, 2019 at 14:31
1

I am having a similar issue with my Data Store validating within AGS and Portal. We are running Enterprise 10.7.1 in a four server federated environment.

The first error below has an error message that reads in part: "Error: failed to validate the server managed database '/enterpriseDatabases/AGSDataStore_ds_xxxxx". The server admin server is accessible and functioning as intended.

What I have tried thus far to get things working (without success): 1. Restart the AGS Data Store on its server (test validation) 2. Within AGS admin changed the Data Store machine format from HTML to JSON (tested for validation) 3. Changed the format from JSON to HTML (tested for validation) 4. Ran the ‘update license’ tool on the DS machine (tested for validation) 5. Restarted the whole Data Store server (tested for validation)

Also, I can remote into all of my servers and they are working as intended.

So I would appreciate hearing ideas on how to resolve this Data Store issue. enter image description here enter image description here

1
  • I do not believe changing the output format between HTML and JSON will have any effect. I believe it is simply how the response is formatted after it completes the action. Have you tried reaching out to ESRI support? If so, and they were able to get you back up and running properly, it may be a good idea to create a new question and answer your own question with the steps you took to fix the issue. Back-end issues like these are not documented very well anywhere so it would be good for us all to try to document solutions for Server when we come across them. Commented May 21, 2020 at 16:36
1

I had a similar issue with my instance on 10.7 using Windows. The week prior to noticing this issue I changed the service account password for my entire stack. I went in and manually changed the password in services, but that's it. I ultimately went into the C:\Program Files\ArcGIS\DataStore\tools on both my primary and secondary nodes and ran the configureserviceaccount.bat and that resolved my issue. This fixed the error message I was getting for both my relational and tile cache data stores.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.