0

I have written a little geocoding for PyQgis script on my linux machine, and it runs just fine there. Now I would like to start using this script for PyQgis (Qgis 3.4.1) on Windows 10 as well. The script relies on the geopy package, which was no problem installing via pip3 on linux ...

I have just enabled python3 with py3_env inside the osgeo4wshell (cannot figure out the version, but it reads "GDAL 2.3.2, released 2018/09/21" at the bottom). Pip3 (18.1) is also onboard. If I try to install geopy (pip3 install geopy) though, it gives me an error:

Collecting geopy   Using cached
https://files.pythonhosted.org/packages/75/3e/80bc987e1635ba9e7455b95e233b296c17f3d3bf3d4760fa67cdfc840e84/geopy-1.19.0-py2.py3-none-any.whl
Collecting geographiclib<2,>=1.49 (from geopy)   Using cached
https://files.pythonhosted.org/packages/5b/ac/4f348828091490d77899bc74e92238e2b55c59392f21948f296e94e50e2b/geographiclib-1.49.tar.gz
    Error [WinError 87] Falscher Parameter while executing command python setup.py egg_info Could not install packages due to an
EnvironmentError: [WinError 87] Falscher Parameter

You are using pip version 18.1, however version 19.1 is available. You
should consider upgrading via the 'python -m pip install --upgrade
pip' command.

Upgrading to version 19.1 won´t work out for me, and I don´t know what the Win Error 87 refers to. So I don´t really what to do or how to install geopy on Windows.

C:\>pip3 install geopy --verbose

gives me a bit more at the end of the response, but I am not sure what it means. After many found links it says this :

[...]
'C:\\Users\\COMPANY-AD~1\\AppData\\Local\\Temp\\pip-req-tracker-5yuonlct' 
Running setup.py
(path:C:\Users\COMPANY-AD~1\AppData\Local\Temp\pip-install-531534ug\geographiclib\setup.py)
egg_info for package geographiclib
    Running command python setup.py egg_info
    Error [WinError 87] Falscher Parameter while executing command python setup.py egg_info Could not install packages due to an
EnvironmentError. Traceback (most recent call last):   File
"C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\site-packages\pip\_internal\commands\install.py",
line 318, in run
    resolver.resolve(requirement_set)   File "C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\site-packages\pip\_internal\resolve.py",
line 102, in resolve
    self._resolve_one(requirement_set, req)   File "C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\site-packages\pip\_internal\resolve.py",
line 256, in _resolve_one
    abstract_dist = self._get_abstract_dist_for(req_to_install)   File "C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\site-packages\pip\_internal\resolve.py",
line 209, in _get_abstract_dist_for
    self.require_hashes   File "C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\site-packages\pip\_internal\operations\prepare.py",
line 298, in prepare_linked_requirement
    abstract_dist.prep_for_dist(finder, self.build_isolation)   File "C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\site-packages\pip\_internal\operations\prepare.py",
line 126, in prep_for_dist
    self.req.run_egg_info()   File "C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\site-packages\pip\_internal\req\req_install.py", line 473, in run_egg_info
    command_desc='python setup.py egg_info')   File "C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\site-packages\pip\_internal\utils\misc.py",
line 659, in call_subprocess
    stdout=stdout, cwd=cwd, env=env,   File "C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\subprocess.py", line 756, in
__init__
    restore_signals, start_new_session)   File "C:\PROGRA~1\QGIS3~1.4\apps\Python37\lib\subprocess.py", line 1155, in
_execute_child
    startupinfo) OSError: [WinError 87] Falscher Parameter
  • you're really going to want to use conda to install the GIS stack on windows – Paul H Apr 26 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.