I have a shape file with polygons and a xlsx sheet, and I need to join their tables using Join attributes by field value in the modeler.

At QGIS 2.18 it works perfectly, but in 3.4.7 the join doesn't work, but if I do a manual join at the properties of the shape, the join happens normally.

I´m looking for some help with this tool to use in the modeler.

Both colums have the same type and size. I already tried to reinstall QGIS and tried on different machines.

Here are some prints to shows the issue.

enter image description here The tables I want to join by the field FUNDO.

enter image description here Set up for the join.

enter image description here Nothing could be matched.

enter image description here

Set up for the manual join.

enter image description here Everything is joined.

1 Answer 1


In my case the auto-detected type of the joinig field in the xls-table did not match the field type of the shp (table: string; shp:integer). Calculated a new field in the shp in string-format with integer-to-string conversion of the data. Result: String-field (xls) <-> String-Field(shp)

  • When I use the "Join attribute by field value" on the same inputs on the QGIS platform it works well. However when I use the same inputs with the same tools in the processing modeler, then it fails. Jul 27, 2021 at 4:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.