1

I am trying to export a map to an image at 600DPI and 1:2,000,000 scale but have the background WMS map stay at a certain zoom level as the text can get really small compared to the other layers I have.

It'll keep the zoom level I want and that is being displayed if I go to export the map as image and just keep the resolution setting as 96DPI but the other layers are 600DPI and I want to keep the quality for printing.

The background layer is WMS

How can I set a certain zoom level so whenever I try to export with whatever settings it will only use that zoom level?

The WMS server is: http://gaservices.ga.gov.au/site_7/services/NationalMap_Colour_Topographic_Base_World_WM/MapServer/WMSServer

and I'm trying to have the zoom level set to look like this https://i.imgur.com/JthE9Fu.png which has nice big text and limited roads etc

  • You need to pass the dpi to the WMS so it can adjust the scale v font size – Ian Turton May 1 at 11:04
  • I think these are just tiles though that are loading aren't they? How would I pass the DPI onto the WMS if it does allow it? – Matt May 1 at 13:36
  • 1
    There's no such concept of a zoom level with a WMS, and a WMS doesn't have a set of tiles (you can set up a cache but it's not a WMS construct). Your request controls the scale through a combination of dpi, bounding box, and image size parameters. As you are dealing hhere with an ArcGIS service, perhaps the following might help: help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//… – nmtoken May 1 at 13:57
  • In that case how would you recommend I export the WMS so I can have the highest resolution at that "zoom level" so I can put use it with my other layers? That link didn't really help me that much as I understand why it is zooming in when I change DPI etc but I want to control it so it will zoom in as much as I want and those pixels wont change if that makes sense – Matt May 1 at 14:26
0

You can export a section of the WMS layer as an image from the map canvas. Turn off all the other layers except the WMS layer. Go to:

Project menu > Import / Export > Export map to image

  • Specify the extent you want to export.
  • Specify the highest resolution that has the size of labels that you want. It will take some trial and error to find the best DPI.
  • Check the box to "save world file" - this saves the layer as a georeferenced image.

Save the export. Add it to your project. If the labels are too small, try again with a lower DPI.

Note: The difference between 96dpi and 600dpi is quite large. The basemap will be noticeably pixellated.

  • After a bit of trial and error I think I have done the best I can with this option. I was hoping I could download the full quality images from the server somehow and then put them in as a layer but this way isn't too far off and it's looking like the best I can do Thanks – Matt May 2 at 0:23
  • Using a WMS is a shortcut, but as you've discovered it has its downsides. The "full-quality images" in the WMS are designed for viewing at higher zoom levels, so the labels and symbols are too small for the scale you're using. The true solution is to obtain all the parts of the basemap, as rasters and vectors or through a WFS (web feature service), and re-create the symbology you like. The answer I posted here is only a workaround. – csk May 2 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.