I will briefly describe my unsuccessful model shown below. It fails at the very last Project Raster step, where I receive an error mesage.

The model: I have a workspace called South America. It contains a folder for every country in South America (I have the same model for each continent...it works when there is no geographic transformation involved in the projection). Each of the country folders (which I iterate over) has a folder called GL30tiles. This folder contains several rasters. I use the Workspace to Raster tool to merge the rasters into a file called GL30mosaic.tif. I then project the mosaiced raster to the South America Albers Equal Area Conic projection.

enter image description here

The GL30Mosaic.tif is in a UTM_WGS_1984 projection. The built-in ArcMap South America Albers Equal Area Conic Projection is in the South American Datum 1969 (SAD_1969). There is a geographic transformation involved in projecting GL30Mosaic.tif(2) to GL30Mosaic_Project.tif.

When I try running the model, I receive the following error message when it gets to the Project Raster step: enter image description here

The Project Raster dialogue box when I run the model looks like this:

enter image description here

If I simply take the GL30Mosaic.tif and project it in South America Albers Equal Area Conic as a stand-alone operation in ArcMap, there is no problem. When I specify the input raster, the input coordinate system automatically updates. I then specify the Output Coordinate System. When I do that, the Geographic Transformation box automatically updates to SAD_1969_To_WGS_1984_14.

enter image description here

It would seem that the automatic coordinate system updating and geographic transformation selection that occurs when I run the project raster as stand-alone does not occur when running in modelbuilder.

I tried passing GL30Mosaic.tif(2) into the Create Spatial Reference tool, and passing the output into the Project Raster tool, making it the input coordinate system and a pre-condition, but then I receive: Error 999999: Error Executing Function, Failed to Execute Create Spatial Reference.

I could do the raster projections in question one-by-one, but it's going to be long and painful. I would like for it to work in Modelbuilder so that I can press run, go to sleep, and come back in 10 hours, but have been unsuccessful in troubleshooting this error.

There was a similar question on the StackExchange here but that question did not involve a geographic transformation. Indeed, when there is no geographic transformation involved, my model runs perfectly. For example, in Africa the output projected coordinate system is Africa Albers Equal Area Conic, which is in WGS 1984, the same as the GL30Mosaic.tif. No problems.

So the crux of the issue here seems to be that Modelbuilder is failing on the Geographic Transformation issue that does not appear when projecting the rasters one-by-one. How to overcome this?

EDIT: I am including the revised model which passes the geographic transformation as a string into the project raster tool. It doesn't completely solve my problem (see my comment in the comment section), but at least the model runs and creates output.

enter image description here

  • 1
    If look at the syntax section of the help file for Project raster tool the geographic_transform is a string, try connecting a string variable containing SAD_1969_To_WGS_1984_14 to that parameter to complete it?
    – Hornbydd
    May 1, 2019 at 20:20
  • Wow, this works. Amazing. But it begs the question, what the heck is WGS_1984_14? Specifically the number 14? It results in the input coordinate system being WGS_1984_UTM_Zone_20S. That makes sense for Paraguay, and that's good, but when I iterate over the country folders, I want the input coordinate system to update to reflect the UTM zone associated with that country's GL30Mosaic.tif. Seems like I need to update the string with each iteration?
    – Alex
    May 1, 2019 at 23:10
  • 2
    #14 is the variant number and is best for Brazil. There are others for the various countries. See this pdf: desktop.arcgis.com/en/arcmap/latest/map/projections/pdf/…
    – mkennedy
    May 2, 2019 at 0:18
  • Thanks @mkennedy. I was looking for something like that. If someone could explain one thing to me...(here I have to admit that my knowledge of coordinate systems and projections could be better). How is it that the transformation SAD_1969_To_WGS_1984_1 has an 'area of use' South America - onshore north of 45°S with an accuracy of 19m while SAD_1969_To_WGS_1984_10 has an 'area of use' Paraguay with an accuracy of 26m?
    – Alex
    May 2, 2019 at 1:01
  • 1
    Although #10 is for a smaller area, it was derived with only 4 control stations. #1 used 84. See EPSG registry.
    – mkennedy
    May 2, 2019 at 1:52

1 Answer 1


Inserting a string variable into the model with the appropriate geographic transformation and feeding it into the Project Raster tool did the trick. This would seem like a very straightforward thing to do but getting this to work was an incredibly finicky process. Lots of error messages, unconnecting and reconnecting tools, reselecting, validating the model, etc... then finally it worked.

This solution works fine if there is only one geographic transformation in question. However, if the model requires new geographic transformations that update with each iteration, this will not work.

Hornbydd and mkennedy should be credited with solving this question, Hornbydd for the string variable idea and mkennedy for the pdf with the names of geographic transformations.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.