0

If I want to manually input a decimal value to Z-coord in QGIS, there's no effect. Only integer values are saved in nodes editor. Operating system Ubuntu 18.04, QGIS 3.6, locale: poland, data and money format: polish.

cannot input decimal value

5
  • What type of field is the z column?String?float?...
    – Fran Raga
    May 3, 2019 at 19:18
  • @FranRaga That's the Vertex Editor, not an attribute table.
    – csk
    May 4, 2019 at 16:41
  • 1
    In QGIS 3.4.1 on Windows 10, I have no trouble inputting and changing decimal places of Z coordinates in the Vertex Editor. Please edit your question and provide some more details: What version of QGIS, and what operating system are you using? What file format (shapefile/CSV/geopackage etc)? What geometry type (point/line/polygon)?
    – csk
    May 4, 2019 at 16:47
  • 1
    One difference I noticed is that my system uses the period for a decimal separator, and yours uses the comma. Just as a test, try overriding your system locale (Options > Settings > General) and choose a locale that uses the period as its decimal separator (eg English UnitedStates). If that fixes the problem, it's definitely a bug and you should make a bug report at issues.qgis.org.
    – csk
    May 4, 2019 at 16:53
  • 1
    Thank You CSK. That was solved a problem. I will report that bug.
    – tomsik
    May 4, 2019 at 20:28

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.