3

I usually install GDAL for Python using the files in GIS Internals. Since when installing packages through pip I was made aware that Python 2.7.16 is being deprecated next year, I went ahead and installed latest Python 3.7.3. When I wanted to go ahead and install GDAL I realized that MSC.1916 is not yet available in GIS internals so I had to go back to 3.6.6 - 64 bit (which is msc. 1900) in order to install GDAL.

Does anyone know when will the latest MSCs will be available or how often are the GDAL installers are updated in GIS Internals?

All the latest 3.6.x and 3.7.x Pythons are MSC. 1915 or 1916 so I could not used them for GDAL.

  • I have the same problem. Have you installed it already? – BallpenMan Feb 16 at 14:00
  • I ended up using Anaconda environments. With it, you can create multiple Python instances (environments) in which you can install all the packages including gdal really easy, as it installs all dependencies automatically. Best way to go in my opinion, to install packages to Python. Give it a try – Symbionte Feb 17 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.