0

I have been getting a series of errors when I try to run r.stream.extract. Here is a copy of what I am getting when I try to run this:

ERROR: Threshold must be > 0 but is 0.000000 F:\OSGeo4W64\Qgis\bin>g.region raster=stream_raster1b94908283ad4921a42d4051074e451f

ERROR: Raster map not found F:\OSGeo4W64\Qgis\bin>r.out.gdal -t -m input="stream_raster1b94908283ad4921a42d4051074e451f" output="F:\Data\QGIS Output\May 06 model\layers\unique stream rast.tif" format="GTiff" createopt="TFW=YES,COMPRESS=LZW" --overwrite

ERROR: Raster map or group not found F:\OSGeo4W64\Qgis\bin>v.out.ogr type="auto" input="stream_vector1b94908283ad4921a42d4051074e451f" output="F:\Data\QGIS Output\May 06 model\layers\unique stream vect.gpkg" format="GPKG" --overwrite

ERROR: Vector map not found F:\OSGeo4W64\Qgis\bin>g.region raster=direction1b94908283ad4921a42d4051074e451f

ERROR: Raster map not found F:\OSGeo4W64\Qgis\bin>r.out.gdal -t -m input="direction1b94908283ad4921a42d4051074e451f" output="F:\Data\QGIS Output\May 06 model\layers\flow dir stream extract.tif" format="GTiff" createopt="TFW=YES,COMPRESS=LZW" --overwrite ERROR: Raster map or group not found

I cannot make heads nor tails of what's going on here. I have tried to set the threshold (I think this is referring to "Use SFD above this threshold"?) but even if that is so I don't understand why the second error of "map/group not found" is happening.

I am new to QGIS and programming.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.