1

I am new to QGIS. I was trying to export .tiff from WMS layer.

WMS URL is :

https://bhuvan-ras2.nrsc.gov.in/cgi-bin/LULC250K.exe

This WMS layer is from bhuvan for lulc data India.

https://bhuvan-app1.nrsc.gov.in/thematic/thematic/index.php

I can successfully add layer to QGIS but fail to save it as .tiff . My settings while saving TIFF file:

export as tiff

Problem is it does not create any .tiff file, even though it reports it has created a tiff. Exporting the layer as another data type (GeoPackage) to the same location works.

Tiff reported as created, but no image is created

How can I save it as .tiff and how to check what formats are supported by a WMS service ?

10
  • Have you tried checking "Rendered image"? May 9, 2019 at 8:10
  • Yes, but still no .tiff created.
    – Noob
    May 9, 2019 at 8:14
  • Please ask only one question per Question (it's the best way to avoid getting fewer answers than questions). If you take the Tour, it emphasizes this.
    – Vince
    May 9, 2019 at 12:18
  • I can both do a direct request for a Tiff, and save a tiff from the service. so it doesn't appear to be a service issue. Do you have permissions to write to the location you selected?
    – nmtoken
    May 9, 2019 at 15:05
  • 1
    You have to set the resolution parameters. Aug 17, 2020 at 19:40

1 Answer 1

0

You can check the output formats available by looking at the GetCapabilities response:

<GetMap>
  <Format>image/png</Format>
  <Format>image/jpeg</Format>
  <Format>image/png; mode=8bit</Format>
  <Format>application/x-pdf</Format>
  <Format>image/svg+xml</Format>
  <Format>image/tiff</Format>
  <Format>application/vnd.google-earth.kml+xml</Format>
  <Format>application/vnd.google-earth.kmz</Format>

or by right clicking the layer in the browser and selecting layer properties.

Also the image formats that are available in the service for use in QGIS are shown in the WMS/WMTS data source manager, as below.

Image encodings

Tiff is available and selecting tiff gives you the tiff through a request like:

https://bhuvan-ras2.nrsc.gov.in/cgi-bin/mapserv.exe?map=/ms4w/apps/mapfiles/LULC250K.map&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetMap&BBOX=5.604149999999999743,66.76200000000000045,37.158299999999997,98.64979999999999905&CRS=EPSG:4326&WIDTH=780&HEIGHT=771&LAYERS=LULC250K_0405&STYLES=&FORMAT=image/tiff&MAP_RESOLUTION=96&TRANSPARENT=TRUE

I'm not sure why the file isn't created when you export it though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.