1

The goal of my project is to create a road sign inspection survey with the ability to take inspection photos. I have some limitations, so I can only work with survey123 NOT collector.

I create the survey from a feature service. There are global IDs, everything is editable, attachments are enabled etc etc.

The trouble arises with the photo. Since I am doing the survey on existing geopoints (aka the signs), I can't just add a photo question. The work around is add the photo question via a "repeat." For this to work, I created a table and related it to the feature service layer then uploaded to AGOL. I really don't know what's going wrong or where to go from here. I'm having a hard time finding documentation on this topic, so I'm hoping someone can assist me.

I get this error message when I try to publish: The custom feature service submission url is not compatible with this survey (Destination relationship not found for table)

2

I figured it out! Turns out I needed a Relationship class for this work. A simple relate does not work.

  • Hi Katie, you can accept your own answer to close this topic, raise the tick sign – aldo_tapia May 10 at 15:42
  • @aldo_tapia Looks like I have to wait 24 hours before I can accept my own answer. But as soon as it's available, I will do so! Thanks for the tip! – Katie B. May 10 at 17:12
  • and thanks for the answer, I'm a user of Survey123 and I didn't know that it could be possible to use relationship classes there – aldo_tapia May 10 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.