2

I'm having an issue in QGIS print composer. I am using QGIS 2.18.

Some of my legend items are displayed in low resolution or are partially cut off. The strange thing is that some groups of the legend are affected, others not, although they are using the exact same symbol and symbol size etc. I have tried en-/disabeling the auto-refresh button, created a new legend from scratch and also refreshed several times using the blue refresh circle button (F5). I cannot get it to work though.

Some legend items appear in bad resolution and are cut off, others are perfectly fine although using the same symbol settings

  • Do these symbols customized such as svg files imported in symbology? – gianfranco di pietro May 13 at 3:53
  • No, they are default symbols, not imported. Like I said, I am using the exact same style settings for two different layers and one layer appears fine in the legend, the other not. I even upgraded to QGIS 3.4, but the problem persists although the resolution is a bit better. But they are still cut off. – mar_copone May 13 at 15:15
  • what style settings are you using? are the symbol sizes defined in map units? – csk May 13 at 16:19
  • nope, they are defined in millimeters, i tried it with different size units but it doesn't change. – mar_copone May 13 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.