0

The Transectizer plugin does not work for the new QGIS version. Any idea how to make it work?

or please suggest me is there any other alternative for it?

  • You can't make it work without the author (or someone else via a fork) updating the plugin to use the new QGIS 3 API. I don't know about alternatives. – user2856 May 16 '19 at 8:07
  • Ok Thanks, I may try with the older version. – uday May 16 '19 at 8:29
1

Uday. I'm the author of Transectizer plugin. I'm sorry you are not able tu use it in QGIS 3 but I haven't had time to upgrade the plugin, despite I've started some time ago. So I can't help you much right now.

Just in case you're in a hurry, what I can suggest you is to check the source code and use the relevant parts of it to create your transects by mean of a python script, creating a CSV file and importing it into QGIS (or creating a shapefile directly, etc)

The relevant functions inside transectizer.py are newTransect and vinc_pt, which is the one where the real magic is done.

Hope it helps

All the best

Jorge

  • Jorge, Thanks for your prompt reply. I will check out the source code. – uday May 16 '19 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.