1

I am completely new to QGIS. I am on a Mac using OS 10.13.6. I have installed QGIS 3.6, and installed Python 3.6.8 per install instructions. I opened a terminal window to check python install:

EricsMacBookPro:~ ericfoertsch$ python
Python 3.6.8 (v3.6.8:3c6b436a57, Dec 24 2018, 02:04:31) 

So I think I am good and on with the show.

I have 10 files I am trying to merge using Raster/Merge tool.

  1. When I enter the file names in Raster/Merge dialog box I get this error:

    'Incorrect parameter value for INPUT' .

  2. If I click on Run as Batch Process and enter same values I get this error message:

    'Wrong or missing parameter value:Input values(row 1)'.

  3. I put double quotes around the file name strings in both input layers and merged file name and clicked Run again. This time I got logged output but with an error:

    GDAL command: gdal_merge.py -ot Float32 -of -o "\"/Users/ericfoertsch/Google Drive/Documents/Condor Scenary V2/New England/Merged Bil file/NewEngland.bil\"" --optfile /var/folders/sy/mbkmjwg12lb1df08dgjw7psh0000gp/T/processing_7e37da37ef8f4cfd89156358b42637eb/fa859f8db49c4623b356e04a58da9fdb/mergeInputFiles.txt GDAL command output: /bin/sh: gdal_merge.py: command not found

  4. I opened a terminal window and typed in gdal_merge.py and it executed so I am not sure why it shows gdal_merge.py not found:

    EricsMacBookPro:~ ericfoertsch$ gdal_merge.py No input files selected. Usage: gdal_merge.py [-o out_filename] [-of out_format] [-co NAME=VALUE]* [-ps pixelsize_x pixelsize_y] [-tap] [-separate] [-q] [-v] [-pct] [-ul_lr ulx uly lrx lry] [-init "value [value...]"] [-n nodata_value] [-a_nodata output_nodata_value] [-ot datatype] [-createonly] input_files [--help-general]

  5. Continuing the saga, I cut pasted the batch command into the terminal window:

    gdal_merge.py -ot Float32 -of EHdr -o "/Users/ericfoertsch/Google Drive/Documents/Condor Scenary V2/New England/Merged Bil file/NewEngland.bil" --optfile /var/folders/sy/mbkmjwg12lb1df08dgjw7psh0000gp/T/processing_7e37da37ef8f4cfd89156358b42637eb/58cfba9edf9f435cb75ca505c11d85ae/mergeInputFiles.txt

    And got an error msg:

    No input files selected.

  6. So I checked the ..../mergeInputFiles.txt file and it was empty. I guess I expected to see the 10 file names I had entered.

  7. So I entered the 10 file names (I am really desperate by now) and tried running the gdal_merge command in the terminal window and got a series of error messages similar to:

    ERROR 4: `/Users/ericfoertsch/NewEngland/USGSBilFiles/n42_w074_1arc_v3.bil' not recognized as a supported file format.

Any ideas?

  • I wasn't familiar with the .bil file format, so I looked into whether QGIS supports it, and found this tutorial. Apparently you need to create support files. – csk May 16 at 16:22
  • I'm not sure but try running the command from another directory without the spaces in the name. I've already hit my head a lot because of the spaces in the folder names. – hugonbg May 16 at 16:34
  • csk - I had moved the .bil files without the corresponding .hdr files, so I thought that might be my problem, so tried again with the .hdr present in same directory, but again no luck. So I deleted the QGIS 3.6 version and installed an older QGIS 2.18.0 version. That seems to be working, so I am going to forge on ahead with output from that version. I am keeping my fingers crossed all will be OK. – Eric May 20 at 23:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.