1

I'm sure it's something I'm missing... In Global Mapper (GM) I've got my workspace loaded.. and I run a script that does nothing more than "EXPORT_RASTER" to KMZ. The orgin rasters loaded in GM will be cropped and saved in different separate .kmz(s) using a grid (polygon shapefile). This is the script:

GLOBAL_MAPPER_SCRIPT VERSION=1.00
SET_LOG_FILE FILENAME="H:\temp\GlobalMapperScriptLogCapoluoghi.txt"
EXPORT_RASTER FILENAME="H:\Lavoro\_dati\Regioni\_Ortofoto_capoluoghi regione\_kmz\.kmz" \
TYPE=KML \
KML_RASTER_FORMAT=JPG \
KML_SUPER_OVERLAY=YES \
KML_TILE_SIZE=1024 \
POLYGON_CROP_FILE="H:\Lavoro\_dati\QU_ritagli_capoluoghi.shp" \
POLYGON_CROP_USE_EACH=YES \
POLYGON_CROP_NAME_ATTR="<Feature Name>" 

Everything works fine but.... the .kmz(s) created with the batch-script are very poor in quality compared to the same identical kmz(s) exported using the manual File-->Export-->Export raster/image format-->KML/KMZ command. i.e. the final kmz of the exactly same cropped area is 40mb exported manually on the contrary it's 24Mb using the script. Moreover, the .kml(s) inside the two different .kmz(s) of the exactly same cropped area are very different (long and "rich" info-text in the manual export, very short and "poor" info-text in the batch script export - see image here attached).

I also tried to use these tags in the script without success:

KML_TILE_SIZE=1024 \
PIXEL_SIZE=1024x1024 \
SPATIAL_RES=1.79663056823901e-006,1.79663056823901e-006 \

What am I missing? What's wrong in my script? I'm using GlobalMapper 19.

batch_script Raster_Export VS manual Raster Export

  • add "DPI=300" > bluemarblegeo.com/knowledgebase/global-mapper-20-1/… looks like it is defaulting to 72dpi – Mapperz May 18 at 15:16
  • Thanks very much @Mapperz! Actually, the new settings ('EXPORT_SCALE=1000 \ DPI=200 \' ) created a bigger .KMZ file size.. but..I don't see a quality improvement when I load it in Google Earth/Garmin 64s. Actually, I think the problem is the text inside the final .KML created with the batch script: all the high-quality indexes .jpg levels (L2,L3,L4..)are missing and only the low-level .jpg index (L1_0_0.jpg) is contained in the .kml generated using the batch script. I'm wondering if there's a way to solve this issue or I'll have to use another way/software(QGIS?)to automate this conversion. – Paolo Pen May 20 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.