I am trying to put together toolbars with model builder tools I created. I followed the instructions on ESRI's page, but it doesn't seem to want to save.

I created the toolbar in ArcCatalog, as well, and it saves fine. ArcMap doesn't recognize that it was created after I close the mxd. I want to have it available for all mxds, and not just the one I save it to.

Edit: The save when I save the MXD, but I want it to save to every MXD I open, not just the one I saved with it loaded.


It seems that you're trying to replace the Normal.mxt file with something customized, similar to this question. Normal.mxt is what you see as "Blank Map" upon opening ArcMap, and is the default template chosen if you cancel out of the Getting Started window.

select template window

Unfortunately, creating and editing .mxt files has been disabled since the update to version 10.x. The only real option is to save your customization to your .mxd file and move a copy of it to the Templates folder.

When you open a template from this window, it merely pulls in its configuration to the new Untitled project, so you are free to edit and adjust without risking harm to your custom configuration.

I made a custom toolbar with some models in it and followed this process. Upon opening ArcMap and selecting the new template, I found the custom toolbar and all models in place.

enter image description here

It's not an ideal solution, and won't apply your configuration to existing .mxd documents, but can at least make it simpler for any new projects you create.

  • Thank you! I saw some instructions on ESRI's Support page about overwriting the .mxt, but they didn't work. It didn't specify which version it should work with. I tried to replicate the settings from ArcCatalog , since I was able to save it there, but that didn't work either. I figured I could save the .mxd file, but didn't want to have to keep opening it and Save As... every time. I will try to move it to my Templates folders. – Smithw1 May 22 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.