0

I am making a tool in ModelBuilder that will allow me to create a fishnet (using Create Fishnet tool) and add field called "Reviewed" in one swoop. I want to use this when QCing data. I can add the field manually no problem, but when I run it through ModelBuilder I get the error below.

The error says it is not valid or it doesn't exist.

I checked with the fishnet and it looked fine. I am not sure what the disconnect is between this step and the Add Field Step.

I tried Parse Path, thinking it was reading the entire Output Feature Class string as the table, but it will not allow me to use that as the input table because the Parse Path returns a string and not an object.

Edit to add current model: enter image description here

  • What version of ArcMap are you using? – JoshC May 17 '19 at 21:45
  • Can you post an image of your model? – JoshC May 17 '19 at 22:03
  • I am using ArcGIS for Desktop 10.6.1. I put the model in my edit. The fishnet was created as intended. It is just using the fishnet for the next part that crashes, I have tried Make Feature Layer, Copy Features, Feature Class to Feature Class, Parse Path (for file name), and also a direct connection to the "Add Field" tool. It works fine when I go back in and add the field. It looks like it is just not reading the input correctly. – Smithw1 May 22 '19 at 17:12
  • Not saying this will fix anything, but best I can tell, the Feature Class to Feature Class serves no purpose. I'd suggest removing it and adding a field directly to the fishnet result. – KHibma May 22 '19 at 17:49
  • @Khibma I agree! It caused the same error when I connected it directly to Add Field. That is why I started trying to convert it to other file types. No luck either way. – Smithw1 May 22 '19 at 18:29
3

The following model runs perfectly fine:

fishnet model

The output fishnet contains the field needed:

fishnet with added field

| improve this answer | |
  • I got an error 00229: cannot open the file (as I always do with each method I try). There shouldn't be a lock on my fishnet. I toggled off "Add to Display" just in case, and still got the same error. – Smithw1 May 22 '19 at 17:17
0

The model I posted in my original post now works. Originally it just the Add Field tools that caused it to crash. For whatever reason it now works. It must have been a network issue.

The other solutions provided in this thread were a big help.

Below are the parameters for my Fishnet tool. I only fill out output feature class (the fishnet) and the extent of the data that I am working with. Since I am putting in the extent of the data and a default grid cell count (10x10), I do not need to put in a grid cell size. I can go back and edit this later if I need to.

The rest is done automatically. enter image description here

enter image description here

ArcToolbox tool interface Create Fishnet model parameters

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.