2

I am trying to export my map project to vector format (i.e. PDF), but somehow cannot get my line thickness right. While a raster export (i.e. PNG) gives me exactly what I have designed, the PDF always comes out too thick, like it can't display thinner lines. Screenshots are below. Any ideas how to solve this?

PNG: enter image description here

PDF: enter image description here

  • 1
    Which version of QGIS are you using? I was unable to reproduce the problem in QGIS 3.6 – Temporalista May 18 at 2:23
  • using 3.4, so you reckon a qgis update could solve it? Did you try really thin lines? It seems to work fine wit all above 1 mm... – Ben Ko May 18 at 3:02
  • 4
    Might be related to the pdf viewer you are using? – ndawson May 18 at 9:17
2

To force a specific line width in the output file (pdf in this case), set the line width in mm instead of points:

line width settings

Layouts will honor this setting and pdf will reflect that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.