0

I am trying to import .tif images into Google Earth Pro, which have been created in QGIS 3.

The image has two colours, black and white, with only two values, 1 and 0, which was represented by each colour.

When this is brought into Google Earth Pro the image aligns in the right location but is just black. I cannot find any way to change its appearance or any information about the data which is held in it. How can I do either of these things?

2

You probably need to convert/render your image to an RGB color image before or during export from QGIS.

Google Earth can only import/display images that have 3 bands: red, green, blue. If your image file only contains one band, with binary data like your 1s and 0s, QGIS recognizes that and gives it a default styling (black & white). But Google Earth only expects 3-band images, and doesn't know what to do with a single band.

There's an easy way to fix this in QGIS. Make sure your raster layer has some styling set, even if it's just black & white. Right-click the layer, select "Save-as" and at the top of the window, look for "Output mode", and set it to "Rendered Image". Now set the rest of your options, including Format = GeoTiff, and export the TIF file again. That rendered image will be a bit bigger file, but it should show up correctly in Google Earth.

  • I should have realised that myself, but I guess I was assuming google earth would have a way of choosing how to represent images with pixel values rather than RGB. Thank you very much for your very detailed answer. :) – user5505559 May 27 at 3:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.