I have a GeoJSON polygon layer which I converted from a shapefile layer. The layer opens up in geojson.io, for example, with no problem, displays the table correctly, etc:


However, in QGIS the Attribute Table only shows one polygon, with "Features Total:146, Filtered:1, Selected:0", see the image below


I've tried to remove this "filter", using SQL to select all the polygons or just a couple of the polygons, then export selected, and still, I only get this one unit, 146.

How can I get QGIS to display the whole attribute table in GeoJSON and other formats?

One caveat: the original shapefile had a "lock" file on it. I don't have this problem when I export to .shp, though if I try to select polygons and export a subset of the original shapefile in any format, I run into the same problem.

  • I just tried a random GeoJSON, works fine for me, both QGIS and geojson.io. Can you please tell how your GeoJSON was achieved, where did you perform that conversion from shapefile into GeoJSON?
    – Taras
    May 21, 2019 at 5:08
  • Are you sure there is no filter on the attribute table? Try choosing "show all features" below the attribute table
    – JGH
    May 21, 2019 at 11:37
  • I converted it using QGIS - Export - Save Features as, etc. I've done this hundreds of times with hundreds of files but for some reason this is the result I get, every time, when i convert this particular file. And I did choose "show all features", I selected all the features and then attempted to save selected for geojson, with the same result. It will only retain the attribute table if saved to SHP as a whole. Total mystery to me. The only thing i haven't tried is to open it in Arc convert and export, but my student license just ran out :/
    – Eddie Arni
    May 21, 2019 at 21:01
  • I'm having a similar problem with a GeoJSON file (coincidentally with 146 features as well). Without any filters applied, the attribute table still shows "Total: 146, Filtered: 140". As a workaround, save as something else, e.g. GPKG. Sep 13, 2022 at 8:58

2 Answers 2


It's probably caused by having the same value in the ID field. Although GeoJSON doesn't require a unique ID, QGIS may be getting tripped up by the fact your layer doesn't have one. Try using field calculator to update the ID field (add @row_number) and see what happens.


I went back to the original shapefile and removed the .lock file, this solved the problem. I guess it corrupted the data when I converted it to geojson.

  • This doesn't add up. Were you looking at the same GeoJSON file in geojson.io as in QGIS? If so, it would have already been completely divorced from the original shapefile. Jun 28, 2019 at 1:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.