0

After installing the geonetwork version 3.2.1 and the plugin of the iso19115-3 everything work fine. But when plugin the lampv2 profile, this error message shows:

## FileError: 'http://localhost:8080/geonetwork/catalog/lib/style/bootstrap-3.0.1/variables.less' wasn't found (404)
in bootstrap.less on line 2, column 1:

1// Core variables and mixins
2@import "variables.less";

3@import "mixins.less"; ##


Raised exception while starting the application. Fix the error and restart.
    Message


    Failed whilst validating schema-ident file C:\geonetwork\web\geonetwork\WEB-INF\data\config\schema_plugins\iso19115-3.2018\schema-ident.xml. Exception message if any is XSD Validation error(s):
    <xsderrors>
      <error>
        <typeOfError>ERROR</typeOfError>
        <errorNumber>1</errorNumber>
        <message>cvc-complex-type.2.4.a: Invalid content was found starting with element 'appMinorVersionSupported'. One of '{"http://geonetwork-opensource.org/schemas/schema-ident":title, "http://geonetwork-opensource.org/schemas/schema-ident":description, "http://geonetwork-opensource.org/schemas/schema-ident":standardUrl, "http://geonetwork-opensource.org/schemas/schema-ident":depends, "http://geonetwork-opensource.org/schemas/schema-ident":schemaLocation}' is expected. (Element: appMinorVersionSupported with parent element: schema)</message>
        <xpath>appMinorVersionSupported</xpath>
      </error>
    </xsderrors>
    Handler 
    org.fao.geonet.Geonetwork
    Exception   
    OperationAbortedEx : Failed whilst validating schema-ident file C:\geonetwork\web\geonetwork\WEB-INF\data\config\schema_plugins\iso19115-3.2018\schema-ident.xml. Exception message if any is XSD Validation error(s):
    <xsderrors>
      <error>
        <typeOfError>ERROR</typeOfError>
        <errorNumber>1</errorNumber>
        <message>cvc-complex-type.2.4.a: Invalid content was found starting with element 'appMinorVersionSupported'. One of '{"http://geonetwork-opensource.org/schemas/schema-ident":title, "http://geonetwork-opensource.org/schemas/schema-ident":description, "http://geonetwork-opensource.org/schemas/schema-ident":standardUrl, "http://geonetwork-opensource.org/schemas/schema-ident":depends, "http://geonetwork-opensource.org/schemas/schema-ident":schemaLocation}' is expected. (Element: appMinorVersionSupported with parent element: schema)</message>
        <xpath>appMinorVersionSupported</xpath>
      </error>
    </xsderrors>
    Stack   
    OperationAbortedEx : Failed whilst validating schema-ident file C:\geonetwork\web\geonetwork\WEB-INF\data\config\schema_plugins\iso19115-3.2018\schema-ident.xml. Exception message if any is XSD Validation error(s):
    <xsderrors>
      <error>
        <typeOfError>ERROR</typeOfError>
        <errorNumber>1</errorNumber>
        <message>cvc-complex-type.2.4.a: Invalid content was found starting with element 'appMinorVersionSupported'. One of '{"http://geonetwork-opensource.org/schemas/schema-ident":title, "http://geonetwork-opensource.org/schemas/schema-ident":description, "http://geonetwork-opensource.org/schemas/schema-ident":standardUrl, "http://geonetwork-opensource.org/schemas/schema-ident":depends, "http://geonetwork-opensource.org/schemas/schema-ident":schemaLocation}' is expected. (Element: appMinorVersionSupported with parent element: schema)</message>
        <xpath>appMinorVersionSupported</xpath>
      </error>
    </xsderrors>
        at org.fao.geonet.kernel.SchemaManager.processSchema(SchemaManager.java:1287)
        at org.fao.geonet.kernel.SchemaManager.configure(SchemaManager.java:226)
        at org.fao.geonet.Geonetwork.start(Geonetwork.java:241)
        at jeeves.server.JeevesEngine.initAppHandler(JeevesEngine.java:448)
        at jeeves.server.JeevesEngine.init(JeevesEngine.java:191)
        at jeeves.server.sources.http.JeevesServlet.init(JeevesServlet.java:84)
        at javax.servlet.GenericServlet.init(GenericServlet.java:244)
        at org.eclipse.jetty.servlet.ServletHolder.initServlet(ServletHolder.java:640)
        at org.eclipse.jetty.servlet.ServletHolder.initialize(ServletHolder.java:419)
        at org.eclipse.jetty.servlet.ServletHandler.initialize(ServletHandler.java:875)
        at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:349)
        at org.eclipse.jetty.webapp.WebAppContext.startWebapp(WebAppContext.java:1404)
        at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1366)
        at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:772)
        at org.eclipse.jetty.servlet.ServletContextHandler.doStart(ServletContextHandler.java:262)
        at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:520)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at org.eclipse.jetty.deploy.bindings.StandardStarter.processBinding(StandardStarter.java:41)
        at org.eclipse.jetty.deploy.AppLifeCycle.runBindings(AppLifeCycle.java:188)
        at org.eclipse.jetty.deploy.DeploymentManager.requestAppGoal(DeploymentManager.java:499)
        at org.eclipse.jetty.deploy.DeploymentManager.addApp(DeploymentManager.java:147)
        at org.eclipse.jetty.deploy.providers.ScanningAppProvider.fileAdded(ScanningAppProvider.java:180)
        at org.eclipse.jetty.deploy.providers.WebAppProvider.fileAdded(WebAppProvider.java:437)
        at org.eclipse.jetty.deploy.providers.ScanningAppProvider$1.fileAdded(ScanningAppProvider.java:64)
        at org.eclipse.jetty.util.Scanner.reportAddition(Scanner.java:610)
        at org.eclipse.jetty.util.Scanner.reportDifferences(Scanner.java:529)
        at org.eclipse.jetty.util.Scanner.scan(Scanner.java:392)
        at org.eclipse.jetty.util.Scanner.doStart(Scanner.java:313)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at org.eclipse.jetty.deploy.providers.ScanningAppProvider.doStart(ScanningAppProvider.java:150)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at org.eclipse.jetty.deploy.DeploymentManager.startAppProvider(DeploymentManager.java:561)
        at org.eclipse.jetty.deploy.DeploymentManager.doStart(DeploymentManager.java:236)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at org.eclipse.jetty.util.component.ContainerLifeCycle.start(ContainerLifeCycle.java:132)
        at org.eclipse.jetty.server.Server.start(Server.java:411)
        at org.eclipse.jetty.util.component.ContainerLifeCycle.doStart(ContainerLifeCycle.java:114)
        at org.eclipse.jetty.server.handler.AbstractHandler.doStart(AbstractHandler.java:61)
        at org.eclipse.jetty.server.Server.doStart(Server.java:378)
        at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68)
        at org.eclipse.jetty.xml.XmlConfiguration$1.run(XmlConfiguration.java:1510)
        at java.security.AccessController.doPrivileged(Native Method)
        at org.eclipse.jetty.xml.XmlConfiguration.main(XmlConfiguration.java:1435)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.eclipse.jetty.start.Main.invokeMain(Main.java:214)
        at org.eclipse.jetty.start.Main.start(Main.java:457)
        at org.eclipse.jetty.start.Main.main(Main.java:75)
    Caused by: XSDValidationErrorEx : XSD Validation error(s):
    <xsderrors>
      <error>
        <typeOfError>ERROR</typeOfError>
        <errorNumber>1</errorNumber>
        <message>cvc-complex-type.2.4.a: Invalid content was found starting with element 'appMinorVersionSupported'. One of '{"http://geonetwork-opensource.org/schemas/schema-ident":title, "http://geonetwork-opensource.org/schemas/schema-ident":description, "http://geonetwork-opensource.org/schemas/schema-ident":standardUrl, "http://geonetwork-opensource.org/schemas/schema-ident":depends, "http://geonetwork-opensource.org/schemas/schema-ident":schemaLocation}' is expected. (Element: appMinorVersionSupported with parent element: schema)</message>
        <xpath>appMinorVersionSupported</xpath>
      </error>
    </xsderrors>
        at org.fao.geonet.utils.Xml.validate(Xml.java:878)
        at org.fao.geonet.utils.Xml.validate(Xml.java:862)
        at org.fao.geonet.kernel.SchemaManager.processSchema(SchemaManager.java:1273)
        ... 49 more
0

The error you have pasted seems related to the file https://github.com/metadata101/iso19115-3.2018/blob/3.7.x/src/main/plugin/iso19115-3.2018/schema-ident.xml#L8`. This schema is not supported by GN v3.2.x. Minimum version required is 3.5. You have available other ISO 19115-3 schema for GN v3.2.x at https://github.com/metadata101/iso19115-3/tree/3.2.x

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.