1

I have a shapefile that only has 2 fields, one of which is the same as one of the fields in the .dbf file. I tried joining these 2 by their common field but after I do so, the 10 other fields in the .dbf get assigned NULL values.

I am using ArcMap 10.5.

Some additional context since I've already done some Google searching:

  • This was initially an Excel spreadsheet but I changed it to a .dbf
  • They are both strings/text (though they are different lengths which I've seen could cause a problem but there doesn't seem to be an easy solution around this)
  • 2
    You can copy/paste Values that you think should match, into a Text editor. Look for leading,training spaces, etc. – klewis May 25 at 0:27
  • 1
    A join on attribute is only going to work if the strings are equal, byte for byte until terminator. – Vince May 25 at 14:48
  • the strings are for sure equal, I even tried creating a sample table copying the shapefile string into my table – Emma Pascoe May 29 at 13:16
1

When the same thing happen with excel file (seem to be most of the time...) my solution is to export the excel to a geodatabase table then do the join with this table.

If there is something wrong with your DBF the export will fail (with excel it's usually the field name that are problematic : contain forbidden characters or reserved name or start with a number...) and you will know what to fix if you need to use a DBF table.

  • thanks for your suggestion! how would you recommend exporting the excel to a geodatabase table? sorry I'm kind of new to GIS, does geodatabase table mean .dbf? – Emma Pascoe May 29 at 13:42
  • No geodatabase are different than .dbf. For exporting the easiest way is to create a new geodatabase (file or personal,for this there is no real difference) by right clicking in the catalog window at the emplacement you want to create it (or use an existing geodatabase) then add you excel sheet in your doc and right click on it to DATA>export... – J.R May 29 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.