6

I am trying to use Italic scientific name in my legend, I am using QGIS 3.4.

I can not figure out how to do only two-word italic without having the rest of the description being italic. Is it possible to italic only the name in a legend description?

3
  • 2
    Can you post a sample picture on how you would like the legend to look like?
    – ahmadhanb
    May 28, 2019 at 1:55
  • 1
    No, it's not possible. The best workaround is the digital equivalent of putting a postit note on something before you run it through a copy machine. Set up an html frame as explained by HDunn below. Arrange it so that the text is arranged with exactly the same spacing as the original legend, and make the background opaque. Then put the html frame on top of the legend, so that it hides the original text.
    – csk
    Jun 6, 2019 at 18:15
  • Since the 3.30 version, it's now possible, see my answer : gis.stackexchange.com/a/456981/93097 Apr 5, 2023 at 10:31

3 Answers 3

7

Since the new QGIS 3.30 version and the integration of this feature request : "Support for HTML in text of legend items", it's now possible to format like this :

legend HTML formated

with this legend title :

Map Species with <i>italic parts</i> or <u>other HTML <span style="color: #ff55ff">formatting</span></u>
1
  • 1
    Fantastic, finally after years of waiting, everyone involved in plant or animal surveys rejoices!! I had missed out on this update in 3.30 so thank you for mentioning it - I cannot wait for this to be in the next LTR.
    – she_weeds
    Apr 5, 2023 at 9:20
5

Use the span tags in an html frame in the print layout. The regular text box only lets you define the style for the entire box, the html frame lets you control individual characters/words.

enter image description here

3
  • Hello, my item properties is not showing me html source input option!! can you please guide me? May 30, 2019 at 10:10
  • @tawhidhossain are you using an html frame item?
    – HDunn
    May 30, 2019 at 12:33
  • Nope, I am just trying to input the legend. May 31, 2019 at 15:28
0

On the right side of your Print Layout Window you switch to the Tab "Element properties" of your legend item. The third point here (below "Legend Elements") should be "Fonts". Here you can configure the fonts used in your legend.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.