1

From one moment to the other I cannot create any polygon anywhere on the map, independent from the layer I am in, even if I create a new shape-file. I have checked all snapping options, enabled them, disabled them completely, restarted everything, etc. but no matter what I do this message pops up:

The feature cannot be added because it's geometry collapsed due to intersection avoidance

It's super weird because even if I create it in absolutely blank space it tells me that the geometry collapsed. It occured when I had print composer open and modified a polygon. I moved the knots of one polygon and then wanted to create a new one which did not work. I checked the polygon of which I had moved the knots 400 times...there is no flaw and no intersection. Frustrating.

I am using QGIS 3.4 Madeira

  • 1
    Please edit the question to provide an example vertex sequence that exhibits this problem. – Vince May 28 at 1:56
  • 2
    Managed to solve it myself. I had a disabled layer that encompassed the entire country (country contour). For some reason, maybe when testing out the snapping features a while ago "avoid intersection" was still enabled. The confusing point for me was that I had disabled snapping altogether so I had thought this would also disable all "avoid intersection" boxes that I had enabled in advanced snapping configurations. However I had to uncehck them individually even though snapping was turned off all together. Dont really know if this is intentional by the developers, but anyway. Lesson learned. – mar_copone May 28 at 2:36
  • Please self-answer, or this question will be closed. – Vince May 28 at 10:40
1

Managed to solve it myself. I had a disabled layer that encompassed the entire country (country contour). For some reason, maybe when testing out the snapping features a while ago "avoid intersection" was still enabled. The confusing point for me was that I had disabled snapping altogether so I had thought this would also disable all "avoid intersection" boxes that I had enabled in advanced snapping configurations. However I had to uncheck them individually even though snapping was turned off all together. Dont really know if this is intentional by the developers, but anyway. Lesson learned.

  • Thank you for self-answering! Many months from now someone else will have the same obscure problem, and they'll google "The feature cannot be added because it's geometry collapsed due to intersection avoidance" and find your Q&A, and it will make their day because you saved them hours of frustrating troubleshooting. – csk May 29 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.